WordPress 6.2.2 恢复块模板中的简码支持,修复安全问题

资讯1年前 (2023)更新 仰望天空
15.2K 10 0

WordPress 6.2.2作为 6.2.1 的快速修复版本,6.2.1 版本引入了一个错误,该错误破坏了块模板中的简码支持。版本 6.2.1 也是一个重要的安全版本,但由于在块模板中使用简码(Shortcode,也做 短代码)的人的灾难性破坏,一些用户正在实施不安全的解决方法或简单地降级到 6.2 以保持关键功能在他们的网站上运行。

WordPress 贡献者在周末迅速工作,以确保用户现在可以更新到 6.2.2,而他们的简码完好无损。发布帖子将上一版本中删除简码支持确定为“回归”和错误。这是一个重要的认识,因为简码仍然是用户经常依赖的工具,用于从尚未作为块提供的插件中插入功能,并且对于没有内联简码就无法工作的东西来说也是必需的。

6.2.2 版也是一个安全版本,核心贡献者 Jonathan Desrosiers 表示,6.2.1 中修复的问题在此更新中“需要进一步强化”。

建议用户立即更新,自动更新正在推出。许多人报告说,在 6.2.1 破坏了他们的网站后,他们关闭了核心的自动后台更新。这样做的用户将需要尽快手动更新。

声明:本站所有文章,如无特殊说明或标注,均为本站原创发布。任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。如若本站内容侵犯了原著者的合法权益,可联系我们进行处理。

© 版权声明

相关文章

没有相关内容!